MFA token not working
Issue
Your MFA token isn't working in Autotask.
Cause
Your time zone information is not synchronizing correctly with the servers.
Resolution
Since authenticator apps like Google Authenticator and Duo compare the time information stored on the phone to that of the Autotask user's time zone, do the following:

In Autotask, the user's time zone is the one associated with their Primary Internal Location. To check your time zone information in Autotask, do the following:
- Navigate to Autotask menu > Admin > Organization Settings & Users > Resources/Users (HR)> Resources/Users (HR) > Resources/Users.
- Take note of the value in the Primary Location column. Make sure the correct internal location is assigned to the user.
- Then, navigate to Autotask menu > Admin > Organization Settings & Users > Your Organization > Internal Locations. Make sure the correct time zone is assigned to the internal location.
- If there is no internal location associated with the correct time zone of the user, you must create a new one and then assign it to the user.


For Android-based devices, you can synchronize manually within the app. To make sure that you have the correct time, do the following:
- Go to the main menu on the Google Authenticator app.
- Click More > Settings > Time correction for codes > Sync now.
On the next screen, the app will confirm that you have synchronized the time, and you should now be able to use your verification codes to sign in. The sync will only affect the internal time of your Google Authenticator app, and will not change your device's Date & Time settings.
For more possible solutions to common issues with Google Authenticator, visit this article.

For iOS-based devices, the time zone is pulled from the device's location services. While you can set the time zone manually, most users choose to have the time set automatically. You can resolve some issues by cycling the automatic time zone setting. To cycle the time zone setting, do the following:
- Launch the Settings app.
- Go to General > Date & Time.
- Cycle the Set Automatically option off and then back to on.
If this doesn't resolve the issue, consult the guide for your OS for how to change time zones. You should also attempt to cycle your zone to another option and then revert to the correct setting, as this usually resolves any localized device issues.
For basic MFA Application troubleshooting, refer to Datto Partner Portal: Getting Started With Multifactor Authentication (MFA).